OtO Lawn

OtO isn't charging

If the battery has died completely (for example, after not using the device in the winter or not being exposed to sunlight), it can take up to 24 hours (in come cases, more than 24 hours) for the unit to come back online.

  • Please check that the two pins in the power plug of the unit are not damaged. If the pins have been damaged, send us a picture.

  • Triple check that the outlet you are using is operational. You'd be surprised how often customers find their outlet is not operational. Try plugging OtO into a different outlet.

  • Ensure the two cylindrical ends are pushed together firmly. You should feel a small click to confirm they are connected. 

  • Ensure the power adapter collar (on the wall adapter) is screwed on tight. It is possible it has gotten loose.

  • Plug in the device using the provided power cable and ensure it is plugged in for at least 24 hours.
  • You know if the device is charging successfully because the LED light will glow solid red (note, it may take some time for the LED to turn on if the battery has been dead for an extended period of time).

Note: If the battery is dead, the device will not get enough power from the sun alone. We suggest you plug it in for 24 hours so you can work with a full charge.

If you are still having issues, please email us at care@otolawn.com and we'll assist you as quickly as we can!

Was this article helpful?
0 out of 9 found this helpful
Have more questions? Submit a request

Comments

Please sign in to leave a comment.